Skip to main content

Login Problem After DNN database Restoring

Dear All
If you are facing the problem in login after restoring database the reason is the machine key is not matching.

This problem arrived because you are restore the whole website from server to workstations so because of this you will face two problems

1) Login accounts not working
2) Pages will not show

for 2nd problem please check my previous blog
http://bestvisualization.blogspot.com/2012/05/pages-are-not-accessing-after-restoring.html

for login you need to resolve it like this

1) Register with the normal user
2) Open the database table users
3) Assign this user as super host  (Please read this post if you don't know about this step http://bestvisualization.blogspot.com/2009/11/how-to-reset-dot-net-nuke-dnn-host.html)
4) Close the database
5) Login with the new user
6) Go to admin > user accounts
7) Click on the pencil and click on password manager
8) Click on the Reset password (system generated random one)
9) Once it done you can assign your own password

After that you will successfully login with the same users

If you want to get rid of all this issue then restore the dnn in the same OS

Like if your orignal dnn version is running on server then restore it on server other wise follow the above steps

I hope this post helps you and save you huge time because i already spend allot of time on it :D

Regard
Rashid Imran Bilgrami
CEO
Best visualization
http://www.bestvisualization.com 

Comments

Popular posts from this blog

How to convert and crack windows server 2012 from Evaluation to Full

Dear All

This is a way how you Convert Evalution to Full

Step1:

Open CMD and run following command
DISM /online /Get-CurrentEdition


<edition ID> is like ServerStandard with out Eval

Step 2:
DISM /online /Set-Edition:<edition ID> /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula



WINDOWS SERVER 2012
Serial Key

Windows Server 2012
DataCenter: 48HP8-DN98B-MYWDG-T2DCC-8W83P
Datacenter: Y4TGP-NPTV9-HTC2H-7MGQ3-DV4TW

Standard: XC9B7-NBPP2-83J2H-RHMBY-92BT4
Standard R2: DBGBW-NPF86-BJVTX-K3WKJ-MTB6V

Server Essentials:K2XGM-NMBT3-2R6Q8-WF2FK-P36R2


For Standard R2 here is a command
For R2 its like that
DISM /online /Set-Edition:ServerStandard /ProductKey:DBGBW-NPF86-BJVTX-K3WKJ-MTB6V /AcceptEula

Regards

RegisterStartupScript updated way to right Java script JS (Javascript) in code behind also work with update panel

Dear All
RegisterStartupScript is obsolete now the new way that works with update panel  is given below its is code behind file code also

VB Code Dim csname1 As String = "PopupScript"
Dim cstype As Type = Me.GetType()
Dim cs As ClientScriptManager = Page.ClientScript
Dim cstext1 As String = "alert('Your message');"
cs.RegisterStartupScript(cstype, csname1, cstext1, True)

C# Code
String csname1 = "PopupScript";
Type cstype = this.GetType();
ClientScriptManager cs = Page.ClientScript;
String cstext1 = "alert('Hello World');"; cs.RegisterStartupScript(cstype, csname1, cstext1, true);
I hope it will help you also 
Regards  Rashid Imran Bilgrami

Calling LoadLibraryEx on ISAPI filter “C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll” failed

Dear Readers
if you get the error

Calling LoadLibraryEx on ISAPI filter “C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll” failed


Here is the solution 
Get a command prompt in administrator mode and go to C:\Windows\Microsoft .NET\FrameWork64\v4.xxx
and run aspnet_regiis -r. This will re-register the right libraries. It has happened twice already to me.
For other frameworks (32 bit or other versions of .net make sure you go to the correct folder (i.e. Framework/v2.xxx, etc.)

xxxx is the the number which is present with the folder name so i suggest you guys to check the folder name in your directory

If "run aspnet_regiis -r" is not working and if you get the error run is not recognized command then just type " aspnet_regiis -r" it will run fine

Reason of problem
Your asp.net frame work has been change may be you have install the lower version on the higher version or may be because of any reason you have register another version in your IIS, in my cas…